How to install mod_wgsi for apache and python3.5 on CentOS 7

It is quite easy to install mod_wsgi on python 3.5 in two steps:

  • To install mod_wsgi on python 3.5 you need to enable IUS  repository first. This command will find and set necessary data automatically:
sudo yum install https://$(rpm -E '%{?centos:centos}%{!?centos:rhel}%{rhel}').iuscommunity.org/ius-release.rpm
  • Then you may simply run yum as below:
yum install python35u-mod_wsgi
  • Done!
  • P.S. pip3.5 install mod_wgsi did not work. Same as sudo yum install libapache2-mod-wsgi-py3 fails. So, suggested option above is the easiest working one. Although is you like spending more time you may try rh-python35 Software Collection which provides a rh-python35-mod_wsgi package.